Friday, February 20, 2009

IP SLA - Timeout or Threshold

Timeout is the maximum time required for SLA operation to complete - for example the timeout waiting for probe response. Threshold is boundary value measured ove the operation RESULT (e.g. RTT, or jitter value collected during the opearation). Crossing threshold usually means SLA contract violation. Note that these two values apply to DIFFERENT objects.

Timeout is directly used to restart the operation. Threshold is used to activate a response to IP SLA violation, e.g. send SNMP trap or start seconday SLA operation.

You should configure the sla based on Frequency > Timeout > Threshold.



For Cisco.com

Q. What does the term threshold and timeout in IP SLA operation mean?

A. Threshold sets the rising threshold that generates a reaction event and stores history information for an IP SLAs operation.
Timeout sets the amount of time an IP SLAs operation waits for a response from its request packet.


Example:

If you configure Timeout > Threshold, you can see the RTT and if the RTT exceed Threshold, it is a failure. If you configure Threshold > Timeout, if the RTT exceed timeout but less than Threshold, it won't show the RTT but it is still a failure.
So failure is RTT exceed either Timeout or Threshold.

ip sla monitor 1
type echo protocol ipIcmpEcho 115.0.0.1
timeout 500
threshold 20
frequency 10

Rack1R6#show ip sla monitor statistics
Round trip time (RTT) Index 1
Latest RTT: 36 ms
Latest operation start time: *04:12:47.001 UTC Mon Mar 4 2002
Latest operation return code: Over threshold
Number of successes: 0
Number of failures: 6
Operation time to live: Forever

Traffic filter

1. Using ACL

2. Using policy-map.

class-map from-bb1
match input-interface fa 0/0
policy-map
class from-bb1
drop.

IPV6 redistribution.

1. By default it won't redistribute the connect interfaces over which the source protocol is running.

To enable it, there is an option " include-connected"

ipv6 router rip 1
redistribute ospf 1 include-connected.

Thursday, February 19, 2009

Auto-RP Access-list filter

To enable rp mapping for special group, you need to configure the send-rp-announce filter first on rp, and the use rp-anounce-filter on rp mapping agent.


1. It is not support fancy acl.
access-list 1 permit 224.0.0.0 8.255.255.255
or
access-list 1 permit 224.0.0.0 1.255.255.255
are same, which will cause the rp announce 224.0.0.0/7 out.
Answer:
8 - 00001000
1 - 00000001
both have 7 bits of 0 so it useing 224.0.0.0/7

You can try 14.255.255.255 and 7.255.255.255.
14 - 00001110
7 - 00000111
and they are same. 224.0.0.0/5


So you should just use all right side 1 ACL, cannot have 0 between 1. Just like network mask.

Reason: In the annoucement and mapping messages, it only carries mask length instead of the whole wide card mask.

Wednesday, February 18, 2009

MLPoFR

In my example, I will show how I bundle two 2 Mbps frame relay line to act as one 4 Mbps line.

We have to do below configuration on both sides.
1)We will make an ordinary frame relay configuration on serial interfaces except “frame-relay interface-dlci 16 ppp Virtual-Template1” line. Here we are adding Virtual-Template1. frame-relay traffic-shaping command is a MUST. (otherwise it will show an error.)
2)Under “interface Virtual-Template1“ we describe that it is a part of multilink interface
3)Under “interface Multilink1” we will configure IP settings.


interface Multilink1
ip address 174.1.23.3 255.255.255.0
no peer neighbor-route
ppp authentication chap
ppp multilink
ppp multilink group 1

interface Virtual-Template1
no ip address
ppp multilink
ppp multilink group 1 (To restrict a physical link to joining only a designated multilink-group interface. By default this command is disabled, which means the link can negotiate to join any bundle in the system.)

interface Serial1/0
no ip address
encapsulation frame-relay
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay interface-dlci 302 ppp Virtual-Template1
!
interface Serial1/1
no ip address
encapsulation frame-relay
serial restart-delay 0
no dce-terminal-timing-enable
frame-relay interface-dlci 312 ppp Virtual-Template1



Note:
1. You can configure both bandwidth under multilink or virtual-template interface. If you only configure virtual-template, the multilink interface will automatically calculator the bandwidth based on how many links. Or if you configure bandwidth under multilink, then it will keep the bandwidth regardless how many links in the bundle.